Blog Post

#2786 Build 1.0.74

brian Mon 2 Mar

We have posted a new build of Fantom for download.

To run this build on Java now requires Java 8 or higher. We have built sys.jar and other Java bytecode to target Java 8 (classfile version 52.0).

Build 1.0.74 (2 Mar 2020)

  • Java 8 runtime required
  • Compiler support for Jigsaw Java 9+
  • Binary integer literals prefixed with "0b"
  • List/Map addIfNotNull
  • Buf.bytesEqual
  • Env.indexPodNames
  • dom: HttpReq.send support for sending DomFile as raw content
  • dom: HttpReq.onProgress callback
  • dom: allow Dialog.title to take Elem content in addition to Str label
  • dom: Event.fromNative
  • dom: Elem.scrollIntoView
  • domkit: Dnd support for DomFiles
  • domkit: DragTarget.onDragImage
  • Enhance Regex to support cross-platform flags
  • Update timezone database to tzinfo 2019c
  • web: WebRes.removeCookie
  • #2673: JS: Unimplemented methods on Pod.js
  • #2760: JS: Backwards compatibility issue
  • #2784: fan.sys.FileBuf.toDigest() bug

Login or Signup to reply.